CPro cann't connect.

I had use CPro board for a few week, but now I got a problem, I can't connect the CPro board, how do I debug it step by step?
I had use Multimeter to confirm V3v and Vgnd on CPro with 2.5 DCmA and it can set up an electric.
By the way coin cell battery is fine.
thanks for help.


  • edited December 2016
    I am having the same issue with a C board. 

    The metawear app now only sees the board if the app is in metaboot mode, and if I connect, it shows the firmware update progress bar for ~10 seconds then gives an error that says "Device disconnected unexpectedly"

    Edit: the 50th time I tried to update the firmware, it worked and the board is now discoverable. 

    I started the metawear ios app in metaboot mode, put a brand new battery into the board, then held the switch down for ~5 seconds and connected. This time it did not time out, and updated successfully. 
  • @kyle
    What mobile device are you using to scan for the device?  Does the metaboot workarond used by @wmeinhold  fix your issue?
  • Sorry for my poor description.
    I could connect CPro do something at last week, but now even scan Bluetooth is not found, that is my problem now.
    So how should I do to fix the problem?
  • As stated in my previous post, does the fix mentioned in wmeinhold's post fix your issue?
  • No, nothing was shown in MetaWear and MetaBase scan.
    So I can't try that process.
  • You can force the board into metaboot mode by holding down the button and inserting the battery.
  • Thanks for the help.
    What signal will show when it get into metaboot mode?
    I had tried:
    1.Holding down the button then inserting the battery.
    2.Inserting the battery first then holding down the button 10 seconds.
    But seems like didn't work.
  • If you're using the iOS MetaWear app, you will need to switch the app into MetaBoot mode.
This discussion has been closed.