Error downloading from MetaMotionR using MetaBase App


When downloading logged data from two MetaMotionR devices, I occasionally get an error for one of them - "Unexpected Error - Could not load device configuration, please try again"

Any ideas what could be causing this or what can be done to fix it?



  • Hi,

    We now have 3 devices (2 of which worked relatively reliably for the first week or so but 1 never worked for us) and just ordered 4 more. Sadly the 2 devices were working relatively well no longer work... We fear the 4 we just ordered will suffer the same fate.

    Could you urgently address this issue?

    We are using the latest version of your App on iPhone. For our purposes streaming is not desirable so we need to download.


    Thank you

  • We are using the MetaBase app to start the two devices logging data at the same time, and then after about an hour of collecting accelerometer, gyroscope, magnetometer, and barometer we attempt to download from the devices, and have seen this problem when we download from one at a time or both.  Both devices work with the MetaWear app but the connection state is normally limited.  We have not been using the Android app because in the past data has taken an excessively long time to download on a Samsung Galaxy S7, making it impractical.
  • edited June 2017
    • What version of the iOS MetaBase app are you using?
    • How fast are you sampling the sensors?
    • Did you do any firmware updates?
    • Does reinstalling the app resolve the issues?
    • Can you try again with the Android app?
      • It would be helpful to know if both Android and iOS apps are failing or it its only one.
  • I am using the latest version of the app and the firmware on both devices is up to date.  Reinstalling the app has not solved this issue.  My question is what in the app is causing this error? ("Unexpected Error - Could not load device configuration, please try again")  It would be helpful to know what the problem actually is so we can try to prevent it.  Or once we see this error is there anything we can try doing to salvage the data that is stored on the device? There seems to be no way to do this in the MetaBase app.
  • That's what we're trying to figure out hence all these debugging steps.  Please see if the boards work fine with the Android app and can you also use the MetaWear app to post the device information for the boards (hardware revision, firmware revision, etc.).
  • While I do expect the firmware/software to be fixed eventually, in the meanwhile, is there a procedure for which MbientLab has found to be very reliable for configuration, logging and downloading data? As the data that we are collecting is not easily reproducible, it is important that we are able to have a reliable system.
  • We have not seen this same error in the Android app, but we have had other problems with the Android app including extremely long download times and crashing during downloading.  The firmware on the boards is 1.3.3 and the hardware is 0.1.
  • Is there any functional or performance difference between the MetaMOTIONR r0.1 and r0.2 boards?
  • @dho
    Are you experiencing the same problems as @jonahk?  If not, please post your issues in a separate thread.

    No, there are neither functional nor performance differences between r0.1 and r0.2 boards.
  • Yes, I am having the same problems as @jonahk.
  • Sorry to hear about your troubles, the "Could not load device configuration" comes from a missing/corrupted data file that the app saves on the iOS device.  This could happen if the app crashes or is forced closed at a time when the file is being updated or saved.

    I would expect a re-installation of the app to fix this.  I'm having trouble re-producing this error here, if possible can you outline the exact steps that led you to this error from a fresh install of the app?

  • After some more experimenting, the error seems to occur when we start multiple devices logging data at the same time, which sometimes takes quite a long time to configure the devices, so I suspect the error is happening somewhere in there.  Is this initial stage the only time the file is used? Maybe it could also be the fact that the phone's screen may turn off if configuration takes a long time.

    Thanks for the help
  • The configuration stage can take a while if their is a significant amount of data already in the log which it must erase before assigning a new configuration.  This is a good hint as to where the error may be coming from, I'll create some more focused test cases today.
  • Have you had any luck with that?
  • It seems to handle the longer configuration time, so unfortunately I have yet to reproduce the problem.  If you can provide more details about the exact steps that led to this error from a fresh install of the app that could greatly speed up debug.  Mention when you background the app and on what screen exactly you see the error, ect.

    Thanks for your help.
This discussion has been closed.