Stuck in MetaBoot state

Hi, I was trying to update firmware from 0.6.0 to 0.9.0 without success.

First, I used MetaWear app from Google Play to do the update but error occurred: "Uploading failed: DFU SERVICE NOT FOUND (262)"
After that I stuck at MetaBoot mode and now I can't connect to this device... I was trying to update firmware few times.

Next, I was trying to upload latest (and later also older versions) downloaded from using nRF Toolbox - but still no success. Error messages were like these:
- mostly "Uploading failed: DFU SERVICE NOT FOUND (6)",
- few times: "Uploading failed: DFU SERVICE NOT FOUND (262)",

Next, I reset device pressing switch while plugging into usb and by connecting pin 20 with GND and then I was trying to upload firmware to "awake" device from MetaBoot mode but MetaWear device is not working properly.

I'm using Lenovo a3500-h running Android 4.4.2. I don't have other Bluetooth LE device.
What else could I try? What could I missed?
Please help. :)

Best regards,


  • Hrm...this is very odd.  Would you happen to have a friend with an iOS device or other Android device that you can borrow?
  • Yes, I borrowed HTC One and Nexus 5 and tried few times but it didn't work.
    Then I borrowed iPhone 5 and at the first attempt error occured. I tried second time and the device finally get updated.
    Now this device work but it's very odd that only iPhone had luck at second attempt.
  • Sometimes I think:
    Android + BluetoothLE = absolute entropy

This discussion has been closed.