bricked MetaMotion R trying to downgrade from 1.4.1

I upgraded the firmware in a MetaMotion R board to 1.4.1 using the Metabase app. I then ran some custom code using the DFU library to downgrade to 1.3.3. I've done this before between 1.3.6, 1.3.4, and 1.3.3 without issue. The process seemed to go fine, with the library updating, but after completion, the board has been completely dead. It won't come up in MetaBoot mode, reset does nothing. Obviously, it's undiscoverable. I'm wondering if there are any hardware pins for reset or some other way to move forward with the, presently, dead board.

Thanks.

Comments

  • What do you mean by "custom code"?

    You'll need to contact support for bricked boards.
    https://mbientlab.com/contact/

  • I mean I effectively used the code from the Metawear-SampleiOSApp, but instead of using the latest firmware which it defaults to, I used 1.3.3. Are there any actual guidelines about downgrading firmware? Is it theoretically possible?

  • Are there any actual guidelines about downgrading firmware? Is it theoretically possible?

  • Do not spam your post multiple times.

    Downgrading firmware is not recommended and generally isn't needed. The updated MetaBase app (which you need to update to v1.4.1) won't let you downgrade from v1.4.1 to the earlier versions anyways.

  • It wasn't spam, it was a bump, given the fact that I got no response and, generally, don't get very good support on this forum. I don't know why you're telling me about the Metabase app when I specifically explained that I'd used a variant of the code you have previously provided in the Metawear-SampleiOSApp. Why have I done this? Because in the past, I have found incompatibilities between a given iOS API and a given firmware so in my app, I have attempted to ensure some kind of versioning such that only a particular firmware version is supported, and the app will upgrade/downgrade a new device to it. When you say "downgrading firmware is not recommended and generally isn't needed", this is not a policy or meaningful documentation. There is also a total lack of compatibility information between iOS API and firmware versions, and this, too is necessary in a production environment.

    I have successfully downgraded firmware before using the above approach, but in the case of 1.4.1, I'm left with a bricked board. If you could provide meaningful documentation or some kind of compatibility chart between iOS API versions and firmware versions, then I might not need to jump through these hoops.

  • Edit: when I say "iOS API", I mean MetaWear iOS API, not iOS itself.

  • Please note that you cannot downgrade from 1.4.1 as the bootloader and firmware have both been updated and previous firmware releases will no longer work.

    If you have bricked your MetaWear, please email us through our contact form (you can ship your metawear back to us and we will re-program it to 1.4.1 for you).

  • Also please note, we do not support downgrading. DO NOT DOWNGRADE YOUR METAWEAR.

  • Thanks Laura. Are there guidelines on which MetaWear iOS API is compatible with which firmware? As I stated above, I've had problems in the past with incompatibilities between the two.

  • edited August 7

    @biofeedbackuwa said:
    It wasn't spam, it was a bump, given the fact that I got no response and, generally, don't get very good support on this forum.

    Your post was still on the front page so it's not like it was lost among a flood of new threads.

    @biofeedbackuwa said:
    I don't know why you're telling me about the Metabase app when I specifically explained that I'd used a variant of the code you have previously provided in the Metawear-SampleiOSApp

    @biofeedbackuwa said:
    I upgraded the firmware in a MetaMotion R board to 1.4.1 using the Metabase app. I then ran some custom code using the DFU library to downgrade to 1.3.3. I've done this before between 1.3.6, 1.3.4, and 1.3.3 without issue. The process seemed to go fine, with the library updating, but after completion, the board has been completely dead. It won't come up in MetaBoot mode, reset does nothing. Obviously, it's undiscoverable. I'm wondering if there are any hardware pins for reset or some other way to move forward with the, presently, dead board.

    Thanks.

    You said you updated the firmware with the MetaBase app so I pointed out how said app behaves when attempting to downgrade from v1.4.1.

    @biofeedbackuwa said:
    Thanks Laura. Are there guidelines on which MetaWear iOS API is compatible with which firmware? As I stated above, I've had problems in the past with incompatibilities between the two.

    The underlying C++ code that the Swift api v3 uses is backwards compatible with firmware down to v1.0.4

    Next time, post these incompatibilities instead of keeping them to yourself.

  • It obviously took that bump to get a definitive, non-ambiguous answer from Laura, something which, for some reason, you were unable to do. Eric, at this very moment, I have an unanswered question on the iOS forum which effectively describes how your new API (which required several additional releases and many complaints on the forum before it would even build!!) is not compatible with ObjC. So my faith in using this forum to resolve issues is typically a last resort.

Sign In or Register to comment.