pods integration with v3.1.4 sdk

Hi all, I can't seem to get the iOS starter project to compile. I'm getting the following error in the Metawear pod:
No such module 'MetaWearCpp'
running latest xcode/pods/osx, sample code from the Master branch.
Have updated and cleaned/rebuilt everything I can think of, multiple pods install/update commands, but just cant seem to figure this out. Does anyone have any suggestions on how to fix this? I figure I must have done something wrong somewhere...

Comments

  • Same problem here.

  • post your current podspec and error messages.

  • kenken
    edited July 25

    Hi Eric, It's the StarterProject from the Mbient SDK for ios/macos/tvos:
    https://github.com/mbientlab/MetaWear-SDK-iOS-macOS-tvOS/blob/master/StarterProject/Podfile
    I have this same issue with my own project too.
    Normally i'd just use:

    pod 'MetaWear'

    In trying to fix this I've tried anything else I can think of or find through this forum/google:
    pod 'MetaWear', :git => 'https://github.com/mbientlab/MetaWear-SDK-iOS-macOS-tvOS.git', :branch => 'master', :commit => '9f1088d716d591a37c65e0a1160aba1a7187ec5c'

    pod "MetaWear", :git => 'https://github.com/mbientlab/MetaWear-SDK-iOS-macOS-tvOS.git', :submodules => true

    pod 'MetaWear',:subspecs => ['Core', 'AsyncUtils', 'UI'], :path => '../'

    Completely stumped on how to fix this one!

    Ken.

  • Sorry for the confusion, but the Bolts-Swift Pod has just been updated so you can go back to using:

    pod 'MetaWear', :subspecs => ['UI', 'AsyncUtils', 'Mocks', 'DFU']

    Note the subspecs are not required but could be helpful based on your needs

  • Also try deleting the Pod folder and re-installing.
    You may need to clean the project (Cmd+Shift+K) or even clean the entire build folder (Alt+Cmd+Shift+K)

  • close...
    getting the following error:

    Installing MetaWear 3.1.4 (was 2.10.1 and source changed to https://github.com/CocoaPods/Specs.git from https://github.com/cocoapods/specs.git)

    [!] Error installing MetaWear
    [!] /usr/bin/git -C /var/folders/rx/mrq5zy513vbbjgn27srv7rv80000gp/T/d20180727-61114-qrtr2u submodule update --init --recursive

    Submodule 'MetaWear/MetaWear-SDK-Cpp' (git@github.com:mbientlab/MetaWear-SDK-Cpp.git) registered for path 'MetaWear/MetaWear-SDK-Cpp'
    Cloning into '/private/var/folders/rx/mrq5zy513vbbjgn27srv7rv80000gp/T/d20180727-61114-qrtr2u/MetaWear/MetaWear-SDK-Cpp'...
    git@github.com: Permission denied (publickey).
    fatal: Could not read from remote repository.

    Please make sure you have the correct access rights
    and the repository exists.
    fatal: clone of 'git@github.com:mbientlab/MetaWear-SDK-Cpp.git' into submodule path '/private/var/folders/rx/mrq5zy513vbbjgn27srv7rv80000gp/T/d20180727-61114-qrtr2u/MetaWear/MetaWear-SDK-Cpp' failed
    Failed to clone 'MetaWear/MetaWear-SDK-Cpp'. Retry scheduled
    Cloning into '/private/var/folders/rx/mrq5zy513vbbjgn27srv7rv80000gp/T/d20180727-61114-qrtr2u/MetaWear/MetaWear-SDK-Cpp'...
    git@github.com: Permission denied (publickey).
    fatal: Could not read from remote repository.

    Please make sure you have the correct access rights
    and the repository exists.
    fatal: clone of 'git@github.com:mbientlab/MetaWear-SDK-Cpp.git' into submodule path '/private/var/folders/rx/mrq5zy513vbbjgn27srv7rv80000gp/T/d20180727-61114-qrtr2u/MetaWear/MetaWear-SDK-Cpp' failed
    Failed to clone 'MetaWear/MetaWear-SDK-Cpp' a second time, aborting

    have tried configuring the pod line with either:
    pod 'MetaWear', :subspecs => ['UI', 'AsyncUtils', 'Mocks', 'DFU']
    or a plain old
    pod 'MetaWear'
    have cleaned the project (just incase) and also pod/clean - pod/update
    maybe I have missed another step?
    Thanks for your help so far, I think we're close to a solution...

    Ken.

  • In the next release I'll setup the submodule to pull from https instead of git protocol. See if that fixes the access issue.

  • Please try the latest 3.1.5

  • Success!!! thanks for all your help!

  • May be I do something wrong but with the new 3.1.6 we have the same problem as describe up.

    no such file or directory: '.../MetaWear/MetaWear-SDK-Cpp/bindings/swift/cbindings.swift'

    Thanks for your attention

  • OK, I guess it is possible to download manually files from :
    https://github.com/mbientlab/MetaWear-SDK-Cpp/releases

    It worked after that but I guess it is not full optimized :-)

    Then, I notice that I had to activate "background mode" for BLE accessories otherwise the metawear scan was not working...

  • @patrice said:
    May be I do something wrong but with the new 3.1.6 we have the same problem as describe up.

    no such file or directory: '.../MetaWear/MetaWear-SDK-Cpp/bindings/swift/cbindings.swift'

    Thanks for your attention

    Are you installing the SDK through CocoaPods?
    If so, can you successfully install v3.1.5 like @ken was able to?

  • I just cloned the git repo for the macOS Metawear SDK. I open the workspace for the StarterProject. I get the same error about the cbindings not being there.

    The pods file looks correct, but the Cpp stuff is not there.

    What is supposed to trigger cocoapods installing that stuff? I have cocoapods installed.

  • I reverted to 3.1.5 and it builds and runs.

  • @tpitman said:
    I just cloned the git repo for the macOS Metawear SDK. I open the workspace for the StarterProject. I get the same error about the cbindings not being there.

    The pods file looks correct, but the Cpp stuff is not there.

    What is supposed to trigger cocoapods installing that stuff? I have cocoapods installed.

    @tpitman said:
    I reverted to 3.1.5 and it builds and runs.

    Can you install v3.1.6 via the Podfile?

Sign In or Register to comment.