firmware update - reboot failed

I was updating the firmware through the meatawer app and after a while it said "reboot failed" and since then I am not able to connect to my device...any suggestion?


  • Did you wait 30 to 60 seconds before reconnecting?

  • I did but nothing happened.i tried again several times after few hours and still I wasn't able to connect
  • Have you tried using the Nordic tools as suggested in our other posts?
  • edited January 2015
    What phone and OS are you using?  Also, what firmware version was your board previously using?
  • I'm using iPhone ios8.1.1. I updated the firmware thru the application (don't remember what version was previously running). I did it for 3 devices but one failed as I describes..
  • Mike,

    Did you check the battery levels on your device?
    Did you try using the Nordic tool to update (see other posts related to this)?
    Did you try using a different Android device or a different iOS device?
    Did you try to scan for MetaBoot using the sample MetaWear App to make sure your board isn't simply stuck in the MetaBoot state? Then you can force an update to kick it out of that state using any of the sample Apps.
    Did you try to reset it?
  • I had to reset (pressing button and connect to usb) a couple of times and finally was able to connect and update firmware.

    one quick question: i noticed that with the new firmware the light (green red or blue) don't stay steady for more than 3 seconds. before it used to stay on as long as it was connected, while right now it doesn't. only the "flag light" mode stays on.
    Is this intentional?
  • Good news!

    With regards to LED, that is the expected behavior now.

    The latest firmware had some power optimizations for LED driver.  In the next iOS app release we will have more LED features exposed that will give all around better control!
  • Thank you!!
  • The sample app has been updated so that the LED will blink forever (as it did before).

    There is also a new API which allows you to choose the number of flashes:

    - (void)flashLEDColor:withIntensity:numberOfFlashes:

This discussion has been closed.