- No such interface supported

I have gone through the tutorials to connect my MetaMotionR via the first metahub tutorial and first python tutorial. I have only been successful in connecting to them once via the metahub. I followed every step multiple times. I have reset the boards and updated the firmware, but to no avail, I cannot get them to connect. I can connect them to the Metabase App and MetaWearAPI app. I keep getting this error below when attempting to connect them via the first python tutorial:

How can this be resolved?

scanning for devices...
[0] C5:A5:43:A5:0C:6A (MetaWear)
[1] 55:6A:8D:47:49:DC ()
[2] C6:EE:8B:E0:4B:24 (MetaWear)
Select your device (-1 to rescan): 0
Connecting to C5:A5:43:A5:0C:6A...
Traceback (most recent call last):
File "", line 37, in
File "C:\Python27amd64\lib\site-packages\mbientlab\metawear\", line 195, in connect
raise result[0]
mbientlab.warble.WarbleException: No such interface supported

No such interface supported
(HRESULT = -2147467262)


  • Update: I can connect to the MetaMotionR sensor via the python Linux tutorial Using the script on the metahub. However, I am still getting the above error when I try to do it on my PC (using the Python windows tutorial).

  • Do you have a Bluetooth Le adapter on your windows machine?

  • I have built-in Bluetooth (version 4.2) on the pc. I tried it on my second PC and got the same error. I was using a Bluetooth adapter purchased from mbientlab on my second PC because it doesn’t have built-in Bluetooth. Both PCs gave me the same error.

  • @SamMasters08
    Can you go back through the tutorial and make sure you have a ble 4.0+ supported ble adapter and then all of the supporting libraries are installed? Basically go through this tutorial and make sure your setup is kosher:
    It would be great if you could post pictures. This will help narrow down the issue.

    Based on the error:

    mbientlab.warble.WarbleException: No such interface supported
    No such interface supported
    (HRESULT = -2147467262)

    It seems some installations steps may have been skipped.

  • Can you connect with the Windows 10 MetaBase app?

  • Hi Eric and Laura,

    Thank you very much for your feedback. Indeed, I didn't check my OS Version assuming that I was running the most updated Version since I recently installed my OS.

    I'll do a better job of completing each task and making no assumptions.

    I greatly appreciate you taking the time to reply.

Sign In or Register to comment.