Issue with Python scan_connect.py

Hello,

I am having trouble running 'python scan_connect.py' in linux. The tutorial page was followed exactly.

I tried 'dmesg' and saw that 'SMBus controller is not enabled' which makes me think this may be the issue.

Comments

  • edited April 23

    Looks like you are missing bluetooth libraries, please make sure you have those installed.
    Follow the bluetooth related steps here: https://mbientlab.com/tutorials/MetaHub.html#build-your-own-hub

  • I followed the steps above and ran into an error on the last step 'pip install pybluez[ble]'

  • I noticed that when I enter 'python --version' it shows python2 instead of 3. However I am unable to install metawear to python 2 .

    I am also wondering if it is necessary to create a hub if we do not have one.

  • edited April 23

    @tpgutowski said:
    I noticed that when I enter 'python --version' it shows python2 instead of 3. However I am unable to install metawear to python 2 .

    I am also wondering if it is necessary to create a hub if we do not have one.

    I didn't ask you to create a hub, I asked you to run a couple of commands related to bluetooth.

  • @tpgutowski said:
    I followed the steps above and ran into an error on the last step 'pip install pybluez[ble]'

    Read my first post. I followed the bluetooth steps and " ran into an error on the last step 'pip install pybluez[ble]' "

  • Try the full install and each step as per the tutorials: https://mbientlab.com/tutorials/Linux.html

  • I did and get the same error.

  • Any other suggestions?

  • Erase your stuff and start fresh from the tutorial since clearly your system is messed up somehow.

    • Can you scan for devices with hcitool?
    • Can you run other scripts?
  • I can scan with hcitool but cannot run other scripts.

  • It seems that each script I try to run has an error in line 3.

    'from mbientlab.metawear .cbindings import'

  • edited April 25

    can't help you if you won't share more information and screenshots
    prove to us your setup is correct...go through every single step of the tutorial...

  • @Laura said:
    can't help you if you won't share more information and screenshots
    prove to us your setup is correct...go through every single step of the tutorial...

    Not a problem, I will share screenshots if you ask me to.

  • Let me know if you need more information or screenshots.

  • @tpgutowski
    If you continue to spam with useless information, you will be banned from this forum

  • @Laura said:
    @tpgutowski
    If you continue to spam with useless information, you will be banned from this forum

    Then please tell me specifically what information or screenshots you would like to see.

  • edited April 28

    What is your error now? metawear is installed so our stuff is fine. It seems your bluetooth or permissions are wrong and that's nothing to do with us...

  • Don't worry Laura, got it to work!

Sign In or Register to comment.