Zero shift in sensor fused acceleration data

Hello,

I'm currently attempting to integrate sensor fused linear acceleration data in order to find the velocity of a swimmer. Here is a graph of velocity that was obtained by integrating the linear acceleration values after denoising procedures were applied.

The graph is inaccurate. It seems as if the sensor is "losing its frame of reference" after the dive and after each turn.

I was wondering what I would have to do to avoid this behavior.

I'm logging data using an MMC board and collecting data through the MetaBase app for IOS. I'm logging both the "quaternion" values as well as the "linear acceleration" values on the app.

Also, I was curious as to the sensor fusion configurations that the app uses in terms of acceleration range and gyroscope range as well as what sensor fusion mode is being used.

Board information:
-- Hardware [0.2]
-- Firmware [1.4.5]
-- Model number [6]

Host Device
-- Iphone 8
-- IOS 13.1.2

Many thanks.

Comments

  • Any update on this topic?

  • @Force, what does your raw data look like after filtering?

    The turn may be too rapid and violent for the sensor fusion to accurately track through it.

    Dead reckoning is a notoriously difficult problem without an absolute position sensor (such as GPS) to correct for drift and other error accumulation due to integration.

    For your described application, heading does not seem to be a critical element so I would recommend IMUplus as the operating mode.

    The MetaBase settings for IMUplus are 100Hz sampling rate, 16g accel sensitivity, 2000 dps gyro sensitivity.

    Matt

  • @Matt Thank you for the suggestion. I'll definetly check it out.

    For clarification, MetaBase uses the IMUplus operating mode when gathering "linear acceleration" values?

  • Yes it uses sensor fusion module to get linear acceration or euler or quaternion. Note that you can only take one of those three to keep maximum sampling frequency 100hz

Sign In or Register to comment.