MetaBase get stuck when I turn on accelerometer, gyroscope and magnetometer with pressure

The MetaBase app worked well when only using accelerometer, gyroscope and magnetometer during log mode. But when I turn on the previous three functions plus the pressure and temperature at the same time, the app will keep configuring without any response. Did you guys meet the same problem when you use the app? I suppose all the functions in the App can be used during log mode at the same time.



  • Are you going beyond the allowed frequency? Maybe if you posted more information...

  • Previous I used default frequency of accelerometer (12.5 Hz), gyroscope (25 Hz), and magnetometer (10Hz). I try it again today and it works fine now. Thanks.

  • I tried to use Euler Angles (100 Hz), Linear Acceleration (100 Hz) and Quaternion (100Hz) under logging mode at the same time, the Metabase App will get stuck on my iPhone 7 Plus. I know the streaming mode will limit the frequency to 100 Hz in total, but not for logging mode, right?

  • You can't do that.
    It's Quaternion OR Euler OR Linear acceleration. The Bosch sensor fusion library can only output one sensor fusion algo at a time.

  • All right. Thanks for the information.

Sign In or Register to comment.