How SensorFusion's mode IMUPlus really works?

2»

Comments

  • Yah looks like it's a bug either on the BOSCH side or our side. We are looking into it but it may take a bit of time.

  • Any update on this?

  • I'm also waiting for a solution. Until we get a fix for this, SensorFusion for me is pretty much useless.

  • We are looking into this and waiting on BOSCH to issue a fix.

  • Considering purchasing some MMR+s for a livestreaming application, but this has me cautious. I'm not sure I'd need this functionality (yet) but if it's inherently not working then I might go with something else. Two questions for mbientlab folks or anyone here who has worked with them:

    1. if/when this issue is fixed, do we know/suspect whether it will be a downloadable firmware upgrade, or will existing hardware always have this issue?
    2. is there a reset button on the board that allows an easy reset to zero the orientation? In my currently-anticipated application that would be fine. (and if there is such a button, is it accessible on the plastic enclosure or only inside on the board?)
  • @robgorbet @alexdpoon @fryjs

    The expected behavior is for the reference frame to reset when the sensor fusion library is internally reset -- this occurs when starting/stopping sensor fusion, or when changing mode settings. However, as seen in your data this does not occur in the present firmware.

    We have a firmware fix tested which resolves this issue. Once firmware QA tests are complete it will be released. We expect that to be this week.

  • @Matt said:
    @robgorbet @alexdpoon @fryjs

    The expected behavior is for the reference frame to reset when the sensor fusion library is internally reset -- this occurs when starting/stopping sensor fusion, or when changing mode settings. However, as seen in your data this does not occur in the present firmware.

    We have a firmware fix tested which resolves this issue. Once firmware QA tests are complete it will be released. We expect that to be this week.

    Thanks for the update

  • @robgorbet

    1. The fix for this issue is in firmware, and will be available for all units as an over the air update.
    2. It will be easily resettable by API, and very likely automatic in existing code -- a stop/start cycle will do it.
  • @Matt said:
    @robgorbet @alexdpoon @fryjs

    The expected behavior is for the reference frame to reset when the sensor fusion library is internally reset -- this occurs when starting/stopping sensor fusion, or when changing mode settings. However, as seen in your data this does not occur in the present firmware.

    We have a firmware fix tested which resolves this issue. Once firmware QA tests are complete it will be released. We expect that to be this week.

    Any update on this? (even an updated eta)

Sign In or Register to comment.