Unable to connect to MetaWear

I installed the Activity Tracker on a Samsung Galaxy S3 with Android 4.3. After a first connect MetaWear disconnected after a few seconds. Now i cannot see the MetaWear device neither in the Activity Tracker nor in the Meta Wear App. Any suggestions?


  • golfngold,

    Can you try using the MetaWear App to reset the board (instead of the Activity Tracker App)?
    Let me know how that goes.
  • Hi Laura,
    thank you for your quick reply. Maybe i did not state clearly that MetaWear does not even appear in the device list when i press Connect in the MetaWear App. (It was only visible once - the first time i started the Activity Tracker App).
    So no chance to reset it, if it is not visible in the device list, am i right? I already pressed the button on the MetaWear (Reset?). No change.

  • A couple of things you might want to try.

    First close down all metawear apps on your phone.  Then try connecting to it with the Metawear app.  If that doesn't work try plugging in the device to a power source to make sure you are not dealing with a low battery or a power issue.  You can also do a hard reset by pressing the button on the top of the unit and then plugging the unit in to give it power.  If none of that works try toggling the radio by putting the device in airplane mode and than taking it back out and also you might want to try rebooting it.  BLE has been known to have shaky support on Android 4.3.  I developed the Android MetaTracker app and tested it on android 4.4 and 5.0,  but there might be some strange stuff that was not accounted for in 4.3.
  • Any updates golfngolf ?
  • Was there a solution to this issue? I am running into the same problem. Downloaded the Activity tracker (Android) and now I am not able to connect to the metawear board (R) at all. Tried everything that was suggested in this thread (hard reset, closing all Metawear apps, even trying to connect with an iphone, etc.)

  • VEmp3,

    Android must be permanently connected to your MetaWear board. You should turn off the Bluetooth on your Android phone (the one with the Activity tracker App on it) and make sure your Android phone is not within connection distance of your board. You can also close/kill all the BLE Apps on the Android phone just to be safe.

    Once you are sure that your MetaWear is not connected to any device at all you can try to reconnect with a different device such as an iPhone using the MetaWear App only.

    Keep us updated.
  • Sounds like we may need to fix this on the Android example App.  Can you let us know what version of Android you are running and also which phone you are using?
  • Laura/ Igleasian -

    I was using Nexus 4 with Android 5.1.

    Had to wait till the battery was dead to reset the board - not sure if the reset button pushed down + power  works when battery is charged.

  • If the battery is plugged in you can't do the button reset trick.
    Thanks for the update VEmp3.
  • I am having this same issue.  I had been able to connect to my three boards with an iPhone and a Kindle Fire, but now neither of these can see any of the three metawear devices.  I have tried taking both of them in and out of airplane mode and resetting but nothing works.
  • edited June 2015

    You will have to remove the battery to use the reset trick, otherwise you will have to wait for the battery on your MetaWear board to fully deplete before you can reset it.

    Please try to take all of your BLE devices far out of range from your board; right now it seems like a device is staying connected permanently to your MW board.

    Keep me updated on your testing methods.
  • I just received my MW board, plugged it into a usb cable and was able to download the app to my Galaxy S4 running android 5.0.1 and it worked for about 5 minutes, then I lost connection to the phone, tried all the methods above and no luck, was completely away from the board today at work and when I came home tried it one more time and my phone does not see it anymore. I will try reset one more time when the battery is dead.

    Should I return it, only had it a few hours?

  • Reset trick worked, don't know for how long, thx..
  • What sensors were you using when you lost connection?  
  • I am also having an issue connecting with my metawear RG. It worked fine when I first received it, but after not touching it for two weeks, it doesn't seem to want to connect at all. I am using the mbientlab app on my iPhone, and nothing shows up under devices.  I tried plugging the device in to make sure it wasn't low on battery (even left it charging overnight), I tried using an Android phone, and even disconnected the battery and then plugged just the board in, but none of these options worked.  Any ideas as to where I should go from here?
  • fblais,

    Are you sure other devices aren't connected to it? We've noticed persistent connection with the latest iPhones/iOS release that make it seem that the device is not advertising when it fact it is already connected.

    Make sure to turn off all BLE devices in range and test with one device and one MetaWear at a time in a secluded area (to avoid all potential issues).

    Also make sure that the RG is charged and that there are not shorts (we've seen some loose battery wires or touching wires that can create shorts and drop connection / reset your board).

    Finally, try other devices besides your Android device.

    Keep us updated so we can resolve this.
  • Laura,

    Thanks for the reply.  So I currently have the battery disconnected.  I went to a relatively secluded area, plugged in the RG to my computer to give it power, and attempted to connect to an iPhone without any luck. The app just shows that it is searching for a device, but doesnt pick up any signal from the RG.  There are no other devices connected to the iPhone.

    Should I reconnect the battery and try the same thing again?  
  • Since you have the battery disconnected, try holding the button down when inserting the USB cable.  This will force the board into bootloader mode.  If the board still does not show up then, its possible it is defective / dead.  We can replace the board for you free of charge provided there is no defect nor damage done to the board.
  • I attempted holding the button down and then inserting the cable, but the board still did not respond.  What is the procedure for returning a defective board?
  • Please send an email to to 'hello at mbientlab dot com' about the situation with your order number.
  • I have the same problem with my 2 RG RPRO..
    From 2 days, the metawear are not simple to find. A day the device found 2 metawear, after some hours, only one. Sometimes neither of them.
    I start to think that it's a problem with the Android 5.0 or more. It's possible? Someone has found a solution?
    I have notice that there is a firmware upade. It's important to make the upgrade?
  • @AngelSara
    What Android device and OS are you using?  Also, can the nRF Connect app see and connect to the boards?
  • edited November 2016
    Only Android 5.0.2.
    Now the metawear are found but some hours ago no.
    After reading something around, I have disconnected the bluetooth (then reconnect) and the metawear are appeared!
    But I'm not sure if this is a random event or not. Maybe it's a problem about Bluetooth on the device with Android 5.0 and more
This discussion has been closed.