Older MTR stuck in Metaboot

Hi all,

I have a MetaTracker from 2019 and it worked fine last time I used it a few months ago. I popped in a new battery, but now it's stuck in Metaboot.

Firmware update fails "No value for bootloader"
I tired Google pixel on latest android 11 and iPad on ios 14.

Model number: 4
Firmware: 0.2.1
Hardware 0.2

I tired all options as well as shorting the pins as described here: https://mbientlab.com/troubleshooting with no luck.

Any thoughts?


  • You can not and should not try to update the firmware or it will put the device in MetaBoot automatically.

  • edited February 2021

    @Laura said:
    You can not and should not try to update the firmware or it will put the device in MetaBoot automatically.

    Thank you for the reply. Metabase literally tells you to try updating firmware in order to kick it out of MetaBoot mode. If this is true, the app should NOT advise to do so.

  • just for more information...

  • Update. I dug out an old iPhone 6 running iOS 12. Downloaded metabase, could not connect. I tried firmware update and it failed the same way. I tried from version # and selecting 1.3.6 without success.

    Any other suggestions?

  • Use MetaWear App

  • Thanks for the suggestion.

    I tried the Android version and it does not locate the device.

    I tried the iOS version on my iPad with iOS 14, and the app sees the device, but when I tap the device to connect to it, the app crashes. I tried uninstalling metabase from the iPad, but that did not help.

    I tried my older iPhone 6, but the app will not install because the iOS on that phone caps out t 12.5.

    Any other ideas?

  • edited February 2021

    Did you try the MetaWear App on iOS? I am not talking about the MetaBase App.

  • Yes. I made sure to use the Metawear app. Running iOS 14.4
    I launch the app, nothing appears. I toggle the switch for "MetaBoot Mode" and I can see my device. I tap the device, it takes me to another screen then the app immediately closes.

    I've tried uninstalling and reinstalling the app. I tried holding the button on the tracker as I insert the battery. I tried another new battery.

  • I got it working! Finally!

    So FYI, I'm a n00b at programming, but last year I was using the pymetawear SDK to simply pull accelerometer data to a data file to be parsed later. I did not create a clean slose command so force killing the app was my only way out.

    I thought maybe that was the reason? So I ran a few example scripts that the SDK provides just so I could make sure it closed properly. I used led.py for this. The script failed every time, but it was able to pull hardware information.

    So I went back to metawear and no luck... no change whatsoever. So I pulled the battery. Left it overnight.

    This morning I put the battery in and tried MetaWear and low and behold it worked! Was no longer in MetaBoot.

    So once I was able to connect and disconnect a few times I went ahead and updated firmware. I am now at 1.3.6!

    Thanks for trying to help. I'm not sure if the script was the fix or pulling the battery, but I tried pulling the battery in the beginning with no luck. Anyway, I'm leaving all this info here in case someone else can use it.

    Thanks again @Laura

  • Awesome d_man, much thanks for the update.

Sign In or Register to comment.