Rebooting the kernel

Hello,
I am programming in Python in Ubuntu and when I want to connect the sensors and configure them it immediately appears that it is restarting the kernel.
Do you know what this problem could be? I have suspicions that it is because of the bluetooth, I use the Bluetooth of my PC, I also tried with a Dongle but the same thing happens.

Comments

  • Can you share more information?

  • HI Laura,

    It happens when I connect two sensors.
    Sometimes I connect the first sensor and the other does not connect and I get the message "restarting kernel".

    When the two sensors are connected, the message always appears on the creator of the fuser.

    I am trying to merge the data from the accelerometer, gyroscope and magnetometer.
    When it enters to configure the sensors and create the fuser, it stops at "e.wait ()", the connection is cut and the error "restarting kernel" appears and returns to the start of the program.

    I try to merge only accelerometer and gyroscope as it is in the examples and it works a couple of times with a very low sample rate losing a large amount of data and then it does not finish the creation of the fuser and everything is cut and the message "Restarting the kernel" appears

    I am programming in Python - Ubuntu with MetamotionR sensors

    SO I do not know if it is now a bluetooth problem or sensor fusion library.

  • In the image you can see part of the code that I was using right in the part of the "e.wait ()" and the messages that I print to know in which part of the code it stops.
    And in the terminal is the message that appears to me. It is in Spanish because it is my language but translating it is "Restarting Kernel"

    Thank you very much for the help, I await your answer

  • What is your code trying to do? It's most likely you are using the fuser incorrectly.

  • I want to get the raw data from the accelerometer, gyroscope, and magnetometer and then use it in an algorithm that I designed.

  • Can you try to do one thing at a time, first acc, then gyro, then mag, then add your algo. Just to start seeing which part of your code is the issue. You will need to use standard debug techniques to narrow this down.

  • That's what I did, I tried each sensor separately and when I use the data fuser from the sensor to have all the data with de epoch it's starting to fail

Sign In or Register to comment.