Metahub timestamp issues

I recently bought a MetaHub. I'm trying to log and download data on my MetaMotionR. I went through the tutorial and want to measure accelerometer and gyroscope at 50Hz. I encounter the problem that the unix timestamp jumps (i.e. jumps equivalent to 6 million seconds). This produces an error in the date and the elapsed time in seconds as well. When using multiple sensors and trying to measure with the same settings, the timestamp error occurs at different times. Further, when downloading from the sensors, the error "received_unknown_entry" occurs a lot. I have tried out a lot but cannot find how to fix this issue. Did anyone have a similar issue? Can you help me?

Comments

  • edited October 6

    Not enough information provided. Please follow the rules at: https://mbientlab.com/community/discussion/3167/how-to-report-an-issue#latest

  • Here are the details according to the How-To

    Board information
    Hardware revision [0.4]
    Firmware revision [1.5.0]
    Model number [5]

    Host Device Information
    Metahub (recently bought), 1 bluetooth dongle
    default settings

    description
    I'm trying to log and download data on my MetaMotionR. I went through the tutorial and want to measure accelerometer and gyroscope at 50Hz with one sensor. I encounter the problem that the unix timestamp jumps (i.e. jumps equivalent to 6 million seconds). This produces an error in the date and the elapsed time in seconds as well.

    What is the expected behavior?
    effortless log and download

    What is observed behavior?
    Warnings during download: warn: received_unknown_entry mac=f8:51:4a:2d:7c:d3
    Timestamps are wrong. Big jumps of millions of seconds.

    What is the set of steps that produces the observed behavior?
    Exactly as in the tutorial https://mbientlab.com/tutorials/MetaHub.html starting from point 9.5 as I have bought the Metahub setup.

    Code in metabase-config.json:
    {
    "command": "download",
    "devices": [

    "F8:51:4A:2D:7C:D3"
    
    ],
    "sensors": { 
    "Accelerometer": 50, 
    "Gyroscope": 50
    }   
    

    }

    MetaBase
    I use the MetaBase application as it is prepared in the Metahub

  • edited October 14

    Do you have data you can share? We will try to reproduce on our end.
    Can you also share the hardware and OS version of your hub? Is it one you made yourself or purchased from us?

  • I am at home office due to the Covid situation at the moment. What I can tell you is that I purchased the metahub from you some weeks ago. So it should have the standard OS and hardware version, that you are selling.

    The data I can share are some test data which I extracted from the hub. These are 3 measurements I have made with 1-2 sensors each time. I used the accelerometer and gyroscope. What you can see is that the timestamp "randomly" (it seems) makes big jumps. It is best apparent with the elapsed seconds.

  • Hi I'm still waiting for an answer,
    Best, steffeol

Sign In or Register to comment.