Problem with MetaMotion C and with Metahub

Dear Sir I am having some troubles with the devices (I have 2). I could connect one of them to my mobile phone (I have used two differents mobile phones, a bq Aquaris 7 and a Lenovo). The other one is in Metaboot mode. I am trying o change to MetaWear mode without success. I have used nrf Connect app as I have read in the forums without success. I have tried to update firmware manually with this app but I couldn´t. I have also replaced battery and make soft and hard reset... If I use an Iphone I coulsolve this problem?

I have also tried to use the Metahub. I have follow the guide (https://mbientlab.com/tutorials/MetaHub.html) without success with any of the 2 sensors. It says that there us a UPdate available 5.6.0 -> 6.1.0.

I am doing my phD of biomechanic applied to tennis. We are using other accelerometers and gyroscope but I wanted to change to your system because of the size, price and g range... I am not programmer. Please I need your help. I think my problem hasn´t a difficult solution. I want to use up 4 sensor with the metahub.

Thanks very much,

Gabriel

Comments

  • You can't just upload any firmware image to your device. What is the hardware revision of board stuck in MetaBoot?

    Which parts of the tutorial are you having trouble with? What have you tried to do with the MetaHub so far?

  • I have just solve the problem with the metaboot. I use an Iphone and now it is no more in metaboot mode....
    With the metahub I can´t record. I have follow the instructions but I have the problem I teld you in the previous message:
    1) I connect the metahub and I connect it to internet by wifi.
    2) I enter the archive metabase configuration and I enter the MAC adress
    3) I click on metabase but nothing happen. Then I try this (all is in the instructions you have):

    4.2.3. Running MetaBase w/Command Line
    If you are having trouble running the app from the desktop for some reason (sometimes there are permissions issues), then you can follow the instructions below.

    Open up a Termit terminal from the top left hand menu and navigate to:

    ~/Apps/MetaBase

    If you browse the directory, you will see that there is an app.js, which is the main MetaBase app, along with supporting files. Open the metabase-config.json file on your desktop and modify the MAC address in the config file if you haven’t already by following the steps in the previous section. Now, copy the “metabase-config.json” from your desktop to the ~/Apps/MetaBase/ directory.

    Launch the MetaBase App using the following command:

    sudo npm start -- --config metabase-config.json

    This will start MetaBase and connect to your MetaWear with the default settings specified in your config file. It will continue to stream, graph and log data until you press [Enter], which terminates the app.

    4.2.4. Data and Logs
    Once you terminate your MetaBase session, all the logs can be found in the ~/Apps/MetaBase/output directory as shown below. The number of logs you will have and how frequent they log data will depend on your configuration file.

    But I get the error I told you below.

    Thanks very much!

  • edited July 2

    Post the contents of the MetaBase config file.

  • {
    "command": "stream",
    "devices": [
    "D3:D1:26:D6:0D:A6"
    ],
    "sensors": {
    "Accelerometer": 50,
    "Gyroscope": 50
    }
    }

  • With the correct indentation

    Thanks

  • Config file looks good; metabase was streaming fine with those settings on my hub.

    What else was printed in the terminal besides the update message?

  • Here I send you the complete error:

    https://we.tl/oWgiDqYMc8

    Thanks

  • edited July 18

    You skipped the first step of the instructions you posted:

    Open up a Termit terminal from the top left hand menu and navigate to:

    ~/Apps/MetaBase
    
Sign In or Register to comment.