Problem with iOS API / Cocoapods (?)

edited June 2018 in iOS


I do have a problem using the API for iOS.

About the environment:
Mac (MacOS 10.13.5)
Xcode (9.4)
iPhone 7 (iOS 11.4)

First i created a new project:

Then i did followed the instructions on Cocoapods (Version 3.1.1) - except one point: I did used the last commit of Bolts Swift (5d06920) instead of the version used at the tutorial.

I opened project using .xcworkspace. First, Xcode didn't accepted import of "MetaWear". After this was solved by a clean und rebuild i do get another exception:

After hours of searching i don't know what's wrong. I would be glad if someone could help me.

Thx in advance,



  • Refer to the StarterProject. See if you can import that into xcode.

  • Hello Eric,

    thanks for your answer. I tried the StarterProject already. It did worked, but i want to create a own project from scratch.

    Many regards,

    Karsten> @Eric said:

    Refer to the StarterProject. See if you can import that into xcode.

  • I've got the same issues here.

    This may be related, but my StarterProject also does not build. It gets:

    error: Build input file cannot be found: '/Users/andrew/Documents/clients/MakerMonster/mbient/MetaWear-SDK-iOS-macOS-tvOS/MetaWear/MetaWear-SDK-Cpp/bindings/swift/cbindings.swift'

    I've checked and there's nothing in that folder.

    I also had to use the later commit for Bolts.

    If I follow the steps to create my own project, I get the same error as the original poster, Karsten, with MBLMetaWearManager not found.

  • Using the version from the 'develop2.0' branch actually works, or at least the initial instructions on the Project Setup page work to connect to the device if you use the Podfile below:

    target 'MetaWearTest' do
      # Comment the next line if you're not using Swift and don't want to use dynamic frameworks
      # Pods for MetaWearTest
      pod 'Bolts-Swift'
      pod "MetaWear", :git => '', :branch => 'develop2.0', :commit => '3ed5a98c1e526d74009c8dab649a6a8dd257b528'
  • The new version uses the C++ library as a submodule so it should read:
    pod "MetaWear", :git => '', :submodules => true, :commit => 'd1c417c'

  • That results in a CocoaPods error: "Unable to find a specification for MetaWearCpp"

This discussion has been closed.