Can't connect to MetaMotionR Windows10

I just got my MetaMotionR in the mail and I've been trying to connect to it with Python2.7 but whenever I try to run the connect command I'm getting this error.

Traceback (most recent call last):
File "", line 37, in
File "C:\Python27\lib\site-packages\mbientlab\metawear\", line 195, in connect
raise result[0]
RuntimeError: Error initializing the API (16)

I tried resetting my bluetooth dongle and updating the firmware with the App like it says in the tutorial, but I'm still getting this error. I can connect just fine with my phone, it's only when trying to connect through Python that it's not working. Any help would be appreciated, thank you.


  • Try increasing the time for response to 4s.

    libmetawear.mbl_mw_metawearboard_set_time_for_response(board, 4000)
  • Thanks for the response, but I got the same error, just took a lot longer to get to it. I'm guessing it might have something to do with the bluetooth adapter itself then? I'm not sure, so I'll post back if I find out that's the issue.

  • @dammage11,

    Yes it looks like it's an issue with the bluetooth adapter, can you make sure it's ble4.2 or above compliant? You should follow the steps in our tutorial here:

    Then I suggest trying with a "know-to-work" ble dongle like the one on our store: (you can get this anywhere like amazon)

Sign In or Register to comment.